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Indexing with Word
Introduction

What�s covered and what isn�t
Welcoming to Indexing with Microsoft Word. In this tutorial, we are
going to look at what documents produced with Microsoft Word are
like, how Word’s indexing module works, and the process require-
ments that Word puts on your indexing work.

The purpose of this tutorial is NOT to teach you how to index, or
what topics or subjects to pick, but rather how to index using
Microsoft Word. We are making the assumption you already know
the basics of indexing, and need to know how to apply that knowl-
edge using Microsoft Word’s indexing module. If you want to learn
the basics of indexing, please see the Appendix for a list of indexing
resources.

This tutorial covers techniques for both Word 7.0 for Windows 95,
and Word 97. For the sake of simplicity, we will call these versions
Word 95 and Word 97.

How to best use this tutorial
It would be ideal to go over the instructions while you are working
at your computer, so that you can try out various techniques as we
go over them. There will be stopping points for exercises you can
try, and the Wright Information web site provides practice files.

The practice files are in RTF format, so that you can open them with
either Word 95 or Word 97. We suggest you download the files to a
folder on your hard drive, and then make copies of the files, so that
you keep a copy of the sample files intact should you want them at a
later time. Instructions for downloading the files are on the exercise
pages.

There is also a spreadsheet included on the web site to help you
schedule indexes. It is in Excel 95 format.
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An overview of embedding indexing

What is embedded indexing?
First off, let’s define what we mean by embedded indexing. What do
we mean when we say Word embeds indexing into its files? The
simplest definition of embedding is the one Nancy Mulvany has in
her Indexing Books (University of Chicago, 1994).

“Embedded indexing software is generally a feature found in word
processing or page design software such as WordPerfect or Ventura
Publisher. Embedded indexing software allows the indexer to insert
index entries (or tags for entries) directly into the document’s text
files.”

In other words, you put the index entries for the book directly into
the same files used to create the book. Many companies use
Microsoft Word to create their manuals and books, writing and
printing directly from the program. Pasting up pages manually and
creating galleys are rarely used in the electronic publishing field.
Everything lives in files, from the time it is written until the time it
goes onto the publisher’s printing plates.

Embedding index codes into these book files allows the publisher to
not worry about what the page numbers are in the index until the
very end, allows the files to go through content and copy-edit
changes after indexing is completed if need be, and allows indexing
codes and text to be reused in the next edition.

How does embedding work?
One concept for understanding indexing codes within Word’s files is
that of “floating.”

The index codes themselves are hidden text, text that is not visible
when the book is printed. You use a dialog box to insert the entries
as a field code, that is, invisible text within the files.
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Page layout before inserting new text

Here’s an index entry, on page 4. If you were to create an index
right now for this piece, you would see this entry as having a page
number for p. 4.

Let’s say you now add some text to this file. After you have added
the text, the index entry floats along to page 5. If you were to create
the index now, you would get page 5 as the page number for the
entry.

Page layout after new text is inserted

Adding pictures can change where the text lies on the page, as can
adding more text, deleting text, or rearranging paragraphs. Through
all of this, the index entries float along attached to their paragraphs,
and do not care what page they are on until the index is created or
“compiled.”

The idea is that the indexing will survive all changes and rewrites,
allowing the publisher great freedom to rearrange the book or update
it, and not have to worry about the “right” page numbers until the
very end.

An index entry

Index entry floated to new position
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Advantages of embedding indexing with Word
You can see embedding indexing may be an advantage in publishing.
Publishers are interested in having the indexing actually be embed-
ded as part of a book’s files for many reasons:

Indexing can begin before the page proofs are ready. This means a
quicker time to publish for some publishers.

If the piece is revised and updated, revisions will not require com-
plete reindexing, but rather reevaluation of the existing indexing, and
additional codes for new material. Since the index is no longer tied
to page numbers, changes in page breaks do not matter. You simply
compile a new index to reflect the changes.

Indexing that lives in the files can be used in other formats, such as
converting the file into an online book with an interactive index.

Translators working with severe deadlines need only translate the
index entries, and not worry about updating the page numbers as
well.

Definitions
Before we go any further, let’s get some definitions for some basic
terms.

Word uses the terms “Main entry” and “Subentry” in its dialog
boxes, and "Cross references," including See references and See also
references. Topics covering multiple pages are indicated with a
"page range." Divider letters or alphabetical heads are specified
when you compile the index.
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Parts of indexes

How Word�s indexing works: the details

Getting started
So how do you index Word files?

Files and concepts
First you must get the files. A book built in Word lives entirely in
files. As an indexer, you may receive one giant file for a project, or
20 smaller ones. Usually publishers or documentation teams break
the book up chapter by chapter, one chapter per file.

When you get the files, make copies and store a set as backups
before proceeding. Do this at every stage.

See also reference
(this one happens to be
a "generic" See also)

See reference

Main entry

Subentry

Entry with page
ranges

Divider letters
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Some publishers or groups use Word’s Master document feature. In
this case, you will get a Master document that contains
subdocuments, and you use the Master Document toolbar to work
with the file. Subdocuments appear as sections of the Master
document. If the piece is in Word 97, you should also get separate
subdocument files as well.

There may be graphics or illustration files included in your book,
files that are necessary for the piece to print correctly. You may or
may not get these separate graphic files as the indexer. Heavily
illustrated books take up a lot of disk space, and if you are working
offsite, you may not have the picture files. If they are missing, you
will see something like this in the files:

Missing picture notation

There may be special font files you need to have installed on your
machine to see the book’s text properly. Your machine may not
display the text correctly without them. Paragraphs could expand or
shrink, headlines may wrap or space oddly, and page breaks could
change enough to make the book look strange.

File management becomes one of the most critical parts of your job
— you must always know which version of the files you have, and
what your editing rights are with them. “Live files” are the ones you
can actually make changes to, ones you actually put indexing entries
into. You should have exclusive rights, and no one else should be
changing their copies if you have the live files. This is a critical
concept. Always know if you have the hot potato in your hands
before inserting index entries.

You will want to carefully set up a folder for your project. Include
subfolders to help you manage your files. One good idea is to create
a subfolder called “originals” where you store backups of the files.
Keep your working copies in a “working copies” folder. Do not store
your files in an open My Documents folder with everything else you
have created in Word. It will only cause confusion!
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When you are done with indexing, you return all files to the client or
production person.

Creating entries
Once you know that you indeed have the “live files,” and that no one
else is working with copies of the files elsewhere, you can begin
indexing them. Let’s start by looking at some existing index entries.

XE fields in text

These are Word’s index entries — they live in invisible XE fields.
Fields are hidden text, as we talked about before. You can tell they
are hidden text by the dotted underlines, and that they are fields by
the curly brackets around them.

We can hide them by clicking Tools > Options command and then
clicking off the check boxes for “Hidden Text” in the View section
of the Options dialog box. And then we can display them again by
choosing Tools > Options and turning “Hidden Text” on again.

An index entry

An index entry
with a
subentry
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To create an entry in Word, you sink an insertion point where you
want the entry to be, and then press Alt Shift X. You type in the text
for your entry, and click “Mark.” Notice how the box stays on
screen. To close the box, click the Xmark in the upper right corner.

   

Mark Index Entry dialog box, and resulting entry in text

Subentries
If you would like to have a main entry with a subentry, press Alt
Shift X, type in the main entry, and type in the Subentry field. Click
Mark, close the box, and examine the entry it has made. Notice how
the subentry has a colon before it. Notice also that you have to
repeat the main entry every time in the codes. Word merges those
down into a traditional looking index, but must have the main entry
specified for each subentry.

   

Mark Index Entry dialog box, and resulting entry and subentry in text
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Quickly copying and pasting entries
You can leave the box open and make several entries in a row, and
you can drag the box around on the screen. But most of the time,
you can work faster without it.

You can quickly copy and paste entries by ignoring the dialog box
and copying the existing XE fields, and then just modifying the
entry. This makes the indexing go much more quickly.

Copying and pasting XE fields

Field codes can be a little hard to select. One good way to get just
the field code and nothing else is to sink an insertion point after the
field code, and then holding down the shift key, tap your left arrow
key once.

XE field highlighted

Notice how it selects the entire field. Fields behave slightly differ-
ently than normal text, as we will see when we are building the
index.

Highlight and
copy this XE
field...

Then paste it in
and edit the
text within the
quotation
marks
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Placing entries
Consider where in the paragraph you want to put your entries. The
best spot is close to the target text, so that if a page is broken
differently, or the text floats, the entry is liable to stay on the same
page with the target.

At times it is not possible to have entries “right next door” — we
will discuss that later in the translation section of the tutorial.

One very quick way to place entries is to highlight the exact text you
want as an entry, and hit Alt Shift X.

Highlight the text you want, and press Alt Shift X. The entry will wind up right
next to the text.

Page ranges for multiple page entries
To create a multiple page entry, you must first create a bookmark,
name it, and then create the entries. To create a bookmark, you must
first highlight all of the text covering the particular subject (any-
where from two paragraphs to many pages), and then choose Insert
> Bookmark (Word 97) or Edit > Bookmark (Word 95) and name
the bookmark.
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Highlight the text you want to bookmark

Name the bookmark and then click the Add button

Always give your bookmarked ranges a unique name, as any
duplications in these names cause problems in the compiling later
on. A good idea is to use the chapter number of the file, and an
identifying word, such as ch5graphics. No spaces are allowed in the
names.

If you later want to view the bookmark’s range, you can choose
Insert > Bookmark or Edit > Bookmark and click “Go To,” and the
highlighted text will show you how far the bookmark extends. You
can also turn on an option in the Options dialog box to show where
bookmarks begin and end. Special marks appear on the text.

   

Beginning and ending marks for bookmarked text
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This is a good tool to use if your text has been changed or edited
since indexing, and you are afraid your ranging may have been
affected.

A new bookmark being added

You can change the order of bookmarks in the box by sorting them
either by name or location, depending on your preferences.

Bookmarking text is a slow process. You need to decide how far a
bookmark extends, and what you will need to bookmark for page
ranges for entries you haven't written yet. What chunks of text are
likely to require page-ranged entries? It often is best to use a printout
to decide the best bookmarks to create for your page ranges, and set
them up before indexing, marking them on your printout, and
making suggestions for yourself before beginning.

Then, after creating bookmarks, you must create the index entry that
refers to the bookmark. Choose Alt Shift X, type in your entry text,
and then click the Page Range button. Choose your bookmark from
the list, and click “Mark.” Close the box and examine the structure
of the entry. The backslash \r code will tell Word to pick up the
bookmarked pages when it compiles the index.
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Choosing a bookmark for a page range, and an XE field with a page range

Again, once you have created one of these page-ranged XE fields,
you can quickly copy and paste what you need. If you have a lot of
bookmarks, however, it might be easier to choose them from the list,
as the names must match exactly in the codes.
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Exercise: Creating entries, subentries, and bookmarks

Download the 1_paleo.rtf file from the Wright Information web site
(http://www.wrightinformation.com/1_paleo.rtf) and save it to your
hard drive. Make a copy of it, and open it up. Because these are
RTF files, you will get asked to convert the file. Click OK.

1. First, make a few entries. Click an insertion point by the words
"Front Range" in the second sentence, hit Alt Shift X, and type
in an index entry for it. The words "Front Range, Colorado"
come to mind as a good one. Click "Mark." Click either the
"Close" button on the bottom or the little X mark in the upper
right corner to close the box, and look at your entry. Ta da!

2. Try making some more entries, this time with subentries. To
create a subentry, add text in the subentry box. Take a look at
the XE fields these create.

3. Now try the easy way of creating entries — copy an existing
one, paste it elsewhere and then modify the text within the
quotation marks to make it fit what you want to index at that
point. For instance, copying the "Front Range, Colorado"
entry, pasting it down near the "bubbling springs of Manitou,"
and then changing it to say something about "Manitou Springs,
Colorado" would be one idea.

4. Now try page ranging. Swipe through and highlight the
paragraphs beginning with "By the time Europeans reached...."
all the way down through the last paragraph. Choose either
Insert > Bookmark or Edit > Bookmark. Name your bookmark
"Utes" and remember, no spaces in the bookmark names.

5. Now insert an index entry up in that first "By the time Europe-
ans..." paragraph, put in index entry text for "Ute Indians," and
then click on the page range button. The list of bookmarks
established for the file appears when you press the little down
arrow. Choose the bookmark you just created.

http://www.wrightinformation.com/1_paleo.rtf
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6. Now let's go back and redisplay the text in the bookmark, so
that later on, when you have forgotten what the "Utes" book-
mark covered, you can remind yourself. Choose Insert >
Bookmark or Edit > Bookmark, click "Go To" and choose
"Utes" and see how the text is all highlighted. You can also
turn on View options in your Options dialog box to show you
marks at the beginning and ends of bookmarks.

7. Save the file and close it. Save it as RTF.

Now that you have experimented with making entries, let's go on to
changing, deleting, and creating other kinds of entries.

Important note: The text for your exercises comes from
Pikes Peak: Legends of America's Mountain, by James McChristal
Sierra Grande Press, HCR 63 Box 619, Raton, NM,  87740,  (505) 445-4313,
and is used with permission by the author. Contact the press for purchasing information.
The book has wonderful old maps and photographs, and is full of great stories, by the way.
Do not duplicate the text for any other reason than personal indexing practice!
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Changing or deleting entries
Once you have created entries, you can change the text or delete the
entry entirely. Click an insertion point within the XE field, and edit
the text within the quotation marks. Or to delete the entry, highlight
the entire field code, and hit delete.

See and See also references
How do you create See and See also references? If you use the
dialog box options to build one, you will see how to format them.
Choose Alt Shift X, click the cross reference button, and create your
See reference. For a See also, add the word “also” to the box, and
make sure you italicize it.

  

Creating a See reference, and the resulting XE field

   

Creating a See also reference, and the resulting XE field
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Once you have created one, it’s easy to copy and paste more as you
need them. Cross references can go anywhere in the text, since they
do not rely on page numbers. But put them somewhere consistently
— perhaps all in the beginning of end of chapters — so you can find
them easily later to edit them.

Generic See references can also be built by choosing Alt Shift X and
typing in your See reference text, then italicizing it.

Generic see reference and resulting XE field

Remember, however, that you have no real automated way to check
that what you have typed is the same as the actual targeted refer-
ence. There are no verifying tools as there are in standalone indexing
packages such as Cindex or Macrex. You have to check your See
references to make sure the item you want your readers to go to is
actually phrased the way you have noted it.

Mismatched See reference

Just keep typing when
you hit the end of the
box: it will scroll
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Exercise: Creating See and See also entries

Download the 2_zeb.rtf file from the Wright Information web site
(http://www.wrightinformation.com/2_zeb.rtf) and save it to your
hard drive. Make a copy of it. Again, the RTF conversion will come
up.

1. See if you can come up with some See and See also references
for this text. Some ideas might be to refer "Mexican moun-
tains" in the second paragraph to "Rocky Mountains." Or you
could make a See also on the third page for "Grand Peak. See
also Pikes Peak." Make sure you make a page reference for
Grand Peak as well.

2. Go through and add a generic reference for "Explorers. See
names of specific individuals". Remember to italicize the text
in the entry properly.

3. Add some real page entries for this chapter too, as we will
want to be sure to see if Word picks them up when we compile
the index. There are several mountain names and personal
names you can add.

4. Add at least one bookmarked entry to the chapter.

5. Save the file and close it. Save it as RTF.

http://www.wrightinformation.com/2_zeb.rtf
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Sorting controls
Suppose you have an entry beginning with a number or a symbol
such as an asterisk, and you would like to sort it under “A” for
“asterisk,” not in a special symbol area. You are no longer out of
luck. Seth Maislin has discovered a way to make Word force how
entries sort! (Yay, Seth!) Look at the example below. Notice how the
symbol section is not sorted the way you would like it to be. You
would really rather have those symbols sorted by their common
names, as they are later on in the alpha section of the index.

Bad sort in the symbols section

To fix this, you want to use a semi colon after the entry to change
the sort. Notice what happens when we add ";*a" and "*pe" and
similar annotations to the symbol entries. Now when it is compiled,
those symbols sort correctly.

Fixing the sort

These entries
create this
index section.
Notice how the
symbols are
sorting

These fixed
entries now
force the
symbols to
sort correctly
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If you want to get Word to ignore prepositions in the subentries you
can do that as well. See how the subentries for the $ sign have had
";cu" and ";pr" added to them. That allows Word to ignore the
prepositions and actually they look out of order, but are correct for
Chicago-style indexing.

Subentries fixed

Thanks to Seth's experimentation, we now can do sort controls in
Word, which is an amazing thing!

You can experiment with these sort controls in entries using periods
and other punctuation marks as the lead characters in entries. Many
technical pieces have to deal with file extensions in the index and
other symbols as leading characters in the main entry. Using the
semicolon will help you sort these where you want them to appear.

Avoid using colons or quotation marks in your entry text, as these
symbols are used within the index codes, and it confuses Word. If
you need a colon or quotation mark, precede it with a \ mark.

Formatting � unwanted and wanted
You can italicize words in your entries, or bold them. Use Ctrl I or
Ctrl B to italicize or bold. You can also italicize or bold the page
numbers by checking off the appropriate radio boxes in the Mark
Index Entry dialog box. One note: avoid putting entries into bolded
headings (like the one above that says "Formatting — unwanted and
wanted), or you can get bold entries in the index.

These fixed
subentries
now force
Word to
ignore the
prepositions
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Where entries go
Consider your placement of entries. Sprinkling them throughout the
text is easiest and most accurate, but makes life very difficult for
anyone who wants to edit or translate your paragraph later. Yet if
you put them in front of a paragraph, and the paragraph is long, the
actual item referenced could be broken across two pages, and the
index will be wrong.

Long paragraphs and page breaks.

Putting an index entry at
the beginning of this
quotation section for an
item in the third para-
graph is fine...

...Unless new text is
added, and the
quotation segment
rebreaks across the
page. Now the third
paragraph with the
actual item is on a
different page than
the index entry for it.
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This is an issue that needs to be discussed with the editor of the
project — what are the plans for this book? Will there be a lot of
rewriting later? Will any of the text be reused for the next edition?
Will the files be translated? If the answer is "no" to all of these
questions, feel free to place entries within paragraphs near your
targets. But if the text will be worked with extensively or translated,
you may need to place all entries at the beginning or end of para-
graphs or sentences.

It would be hard to work around these scattered entries. You can't swipe through
the whole paragraph and rewrite it or replace it with a translation.

Putting the entries at the beginning makes it easier to work with later, but if a
paragraph gets broken across two pages, could lead to inaccuracies.

We will be discussing translation later in the tutorial.

If your pages get broken in such a way that you have wind up with
two duplicate entries on the same page, don’t worry. Word will
merge them into one, and you won’t notice it.

Inserting entries in Master Document subdocuments
If you receive a Master document with subdocuments, you may find
it easiest to work with the subdocuments separately as you create
your entries. You can open each subdocument by itself, and create
entries. Then when it is time to compile the index, use the Master
document itself. We will be covering that step later when we talk
about generating the index.
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Generating the index � RD fields
First, check all your chapter files, and turn off all hidden text
display. This is important to accurately get page numbers the way
the piece will print.

Then, in its simplest form, you create the index by going to a blank
page or creating a blank file, defining all the files to be included with
RD fields and inserting the index.  Create a new blank document by
choosing File > New. If you have a predesigned template that you
always use, base the new document on it, otherwise just hit okay.

Choose Insert > Field, then choose Index and Tables from the
categories list. On the right side of the dialog box, choose RD to
insert the RD fields. In the text box below, add quotation marks, and
put in the name of your first content file. Then click OK. Look at the
field on the page. If you cannot see it, turn on hidden text display in
your options dialog box. These fields tell Word which files to
include, and in what order. It is important to get the order right.

   

Insert Field dialog box and resulting RD field

Put in a carriage return, and then enter the rest of the fields with
their file names. Putting in the carriage returns helps make the
display clearer.

Note that these fields are very simple. If your files live in another folder, you
must include the path to that folder in order for the index to compile. It is easiest
to put everything in one folder.

Make sure the file name is exactly the
same, capitalization and all
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To create the index itself, choose Insert > Index and Tables, and
then choose a template-based formats. You have a variety of formats
to choose from.

Insert Index and Tables dialog box

Format choices are shown in the lower left box. You can also choose
the number of columns on the page, and modify and customize the
index’s styles.

Notice the difference in the preview pane.

Choosing this style will get you these results:

Not exactly my first choice for a format, but this is what you would get.

Click here to see all
the different
formats you can
choose from
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Whichever format you choose, you need to know that your index is a
field, just like the index codes themselves. If you do not see the index
entries after compiling, but get a screen like the one below, you have
your display settings set incorrectly. Choose Tools > Options and
turn off the Field Codes display.

An index is actually a field.

Notice that when you click in the index, the entire index turns grey.
This shows you it is a field.

Grey means field-generated text.

Your entire index is
here in this field,
but you must turn
off "Field codes"
to see it.
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Generating the index � Master documents
Some projects use a Master document to control which files are in
the book. When you build an index using a Master document, here’s
what happens.

First, open the Master document, switch to Master Document View
by choosing View > Master, or clicking this icon (  )and then
expand all the subdocuments. You expand the documents using this
icon (  ). You can hide them the same way, but we need them
expanded.

A Master document with unexpanded subdocuments

A Master document with subdocuments expanded, and index codes showing
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Hide the index codes and other hidden text.

Index codes hidden.

Scroll to the end of the document, and click an insertion point where
you want the index to be. Choose Insert > Index and Tables, and
choose an index format, just as we did with the RD method. Here
you won't need to use the RD method, as the Master document
knows all about its own subdocuments.

Scroll to the end of the Master and subdocuments.

Be sure to click
outside the
last
subdocument!
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Your index becomes part of the Master document.

Inserted index at end of Master document.

It looks rather odd, because we are looking at things in Master
View. Choose Normal view again, and the index will look much
better.

Index viewed in Normal view
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Understanding snapshot indexes
When compiling your index, you also need to be aware that the
index you see is not linked to the codes — it is just a snapshot of the
book at this point of time. If you edit the index itself, those changes
are not reflected in the index codes. All those edits will disappear the
next time you compile the index. You must edit the XE codes
themselves to have lasting changes.

Likewise, if the book changes, and more material is put into it, or
rearranged, those changes are not reflected in the index until you
recompile it.

When the pages roll, the index doesn't update automatically. You must update it!

Updating indexes
Once you have generated the index, you can recreate it and update it
at any time by clicking an insertion point into the index, and
pressing F9.

Deleting indexes
To delete an index, highlight the entire index, and hit delete.
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Exercise: Generating indexes for simple and master documents, and
recompiling

Download the 3_names.rtf file AND the master.rtf file from the
Wright Information web site (http://www.wrightinformation.com/
3_names.rtf and http://www.wrightinformation.com/master.rtf) and
save it to your hard drive. Make a copy of both files.

Open the 3_names file and insert some indexing so that you will be
able to tell if the file is picked up later on when you compile. There
are lots of names of mountains and people you can use to make
entries quickly.

To generate a simple index:

1. Open all three files we have worked with - 1_paleo, 2_zeb, and
3_names.

2. Turn off all hidden text, so that you don't see the XE entries.
Close the files and save them. Keep them in RTF format.

3. Create a new blank word file, and choose Insert> Field, then
choose Index and Tables from the categories list. On the right
side of the dialog box, choose RD to insert an RD field.

4. Fill in the RD field with "1_paleo.rtf" and click OK. Look at
the field on the page. If you cannot see it, turn on hidden text
display for fields in your Options dialog box.

5. Put in a carriage return, and then repeat the process with
2_zeb.rtf and 3_names.rtf.

6. To create the index, choose Insert > Index and Tables, and then
choose a format. Click OK and see what you get. See if all
three files' entries show up. If not, check your RD fields to
make sure the name of the file matches exactly. Make sure they
are all in the same folder with the index document. Remember,
if you do not see the index, but only see weird fields, choose
Tools > Options and turn off field display.

7. Try clicking in the index and watching it turn gray. It is a field.
Go back and change some of the entries in the original docs,
and regenerate the index by clicking in it and choosing F9.

http://www.wrightinformation.com/3_names.rtf
http://www.wrightinformation.com/3_names.rtf
http://www.wrightinformation.com/master.rtf
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To generate an index using a Master document:

1. Open master.rtf, and switch to Master Document View by
choosing View > Master, and then expand all the
subdocuments. Because these are RTF files, you will get
messages about converting the files. You should see the
contents of 1_paleo, 2_zeb, and 3_names.

2. Turn off all hidden text, so that you don't see the XE entries.

3. Scroll to the end of the document, after the subdocuments, and
click an insertion point where you want the index to be. Choose
Insert > Index and Tables, and choose a format. Your index
becomes part of the Master document.

6. Again, experiment with it by changing entries in the files and
regenerating the index.
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Troubleshooting the index
You may get error messages or unexpected results when you com-
pile your index. Let’s look at some of the things that can happen.

If you do not see the index entries after compiling, but get a screen
like the one below, you have your display settings set incorrectly.
Choose Tools > Options and turn off the Field Codes display.

Remember to view your index with Field Codes turned off.

If your page numbers do not match the book, there may be a couple
of things going on. Did you turn off all the hidden text display
before compiling? Are you using the same printer driver as the
production staff that built the book? No? Read the next section on
printer drivers before continuing. Is the index the most recent
version, or do you need to update it because the book has changed or
been repaginated? Remember that your index is a snapshot.

Or, a more serious problem is that a section break marker or a page
break marker has been defined as hidden text, so that what you think
a page range should be is not what is displaying. Check for these
problems.

When you have a large index, you can run out of memory while
having Word processing it. To get around this, you can build your
index in sections. To do this, instead of using the normal Insert
Index command, you use the Insert > Field command. Choose Index
and Tables from the categories list, and then choose Index from the
right side.
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Insert Field dialog box

Click the Options button. Choose \p and click the Add to Field
button. In the text box below, add “a-m” and then click okay. When
your index compiles, it will contain only entries from A through M.
You then click an insertion point below the A-M index, and add
another field using the exact same process, except for substituting
“n-z."

Field Options dialog box, with settings for building half the index at a time

If you see an error stating “Error! Bookmark not defined,” it means
that you need to update the entire index. Press F9.
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Understanding printer drivers
When compiling your index, you need to be aware that the file you
generate is not the final file, only a sample for your use. The final
file should be generated on the same machine used to break the
pages and send the book to the printer. This is because having
different printer drivers targeted will cause Word to repaginate the
document before compiling the index, a process that could change
where text falls on every page. The index will be wrong if it is not
generated on the same machine that is used to print the piece.

Unusual page numbers
Suppose your piece has unusual page numbers, such as A3-A5, or
Chap.10:2. How do you get these picked up correctly in the index?

This takes some work on the production and writing side of the book
before it ever gets to indexing. The chapter titles and headings in the
document must be formatted with the built-in heading styles (Head-
ing 1 through Heading 9). This is done using the Format > Bullets
and Numbering command in Word 97, then choosing the Outline
Numbered tab and selecting a chapter numbering style. (In Word 95,
the command is Format > Heading Numbering).

Choose an outline numbering style for all the documents.

Then the page numbers must be set up as well. From within a
chapter, choose Insert > Page numbers, and then click Format. In the
Page Number Format dialog box, set the heading style applied to the
chapter titles, and then choose the character you want to separate
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your chapter numbers from page numbers (such as a colon or a
dash). This Insert Page Number formatting routine must be done for
every document (or every subdocument in a Master document).

Page Number Format dialog box

To get the numbers to appear in the index, choose Insert > Field,
then choose Numbering and SEQ. Edit the field to read "SEQ
chapter \h \r9 \*\alphabetic".
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Then choose Insert > Field, then choose Index and Tables from the
categories list, and choose Index from the right side of the box. Click
the options button, and edit the field so it reads "Index \h “A” \!-Z \c
“2” \s chapter". And hit OK twice.

Insert Field dialog box with setup for chapter numbering

Chapter numbering in the index

These codes (the \h and the \*, etc.) are known as switches. You can
find out more about what they do by searching Word’s help file
index under “Switches.” They are very powerful and allow you to
format your index precisely.

If you can’t see the index, hide the field codes by choosing Tools >
Options and turning off the field codes.



39

Word indexing

Customizing the index format
As mentioned above, you can use switches to customize how the
compiled index looks, but it is usually easier to customize the index
by working with the Index and Tables dialog box. When you insert
an index, all the entries have styles applied to them. Main entries are
styled with “Index 1” style. Subentries are styled with “Index 2,”
and so on. The alphabetic dividers are styled with “Index Heading.”

To change the look of the index, modify the style itself in the Style
dialog box, and all your entries that use that style will change
automatically. For instance, you can change how much the suben-
tries are indented by modifying the indent for Index 2. Or you can
make all the alphabetic dividers larger, and add space above them,
by modifying the Index Heading style.

Modify the index level style by clicking the Modify button

To modify an indent, choose Style from the Format menu, choose
the style you want to change, and click Modify. Add more indenta-
tion by clicking the Modify button again, and then choosing Para-
graph from the Format popup. You can play with the amount of
indentation in the “Left” box, and preview the effects. Okay your
way out of the dialog box when done.



Word indexing

40

Separate author indexes
If you need to create more than one index for the same material, it
can be done. It relies on using switches, as we looked at earlier for
the chapter numbers. In this case, you tag the index entries for the
special index with a switch, and then use a special field to pull out
just those entries. They will not appear in the main index, and will
only appear when you build a separate index for them.

Let’s say you want to create an authors cited index. As you index
the files, each time you hit an author’s name, modify the index entry
by adding a \f and “author”.

An author-index entry

To create the special author index, choose Insert > Field, choose
Index and Tables from the categories list, and Index on the right
side. Click the Options button, and edit the field to read "INDEX \f
“author”". You should get an index that consists solely of the entries
you tagged with the “author” switch.

  

Insert Field dialog box for author index, and a section of an author index
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Using Word�s indexing in the publishing process

The indexing process
Now that you have seen how the technical steps for indexing in
Word, how do you fit indexing and Word’s special techniques into
your publishing process?

The first step is the same for all indexing projects, Word or not:
reading the material for audience, content, approach, scope.

Make a backup copy of all files — Always keep a clean set of files,
and create backup copies at appropriate times so you can return to a
previous stage if you have to.

Creating your entries — This part can happen in stages, but should
go from the beginning to the end of the book in order. You will need
to know if you have the “live files” and that no one else is making
changes to any copies present on the network or on their machines.

Compiling for the edit — In order to edit the index you will have to
compile it into its formatted version. You will need all the files. Print
out the compiled index to look at, edit, and work from. All chapters
must be read and all entries must be written before starting the
editing process.

Editing — Once the material has had entries created, the index is
edited for consistency and scope, and the cross reference structure is
built. All chapters must be read and all entries must be written
before starting the editing process, as this is the time to refine and
rewrite each entry to fit into a polished whole. The indexer works
through the compiled index alphabetically, and can see how each
topic fits into the whole.

Incorporating edits — Then you have two tasks: edits you can make
to existing entries (corrections, spelling changes, deleting) and
additional new entries you will need to create in the files. You have
to go back to the actual page to add new entries or edit existing
entries. Do not make the mistake of editing the text of the compiled
index. You must edit the entry codes themselves, or the next time
you compile, all editing work will be lost.
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Recompiling and formatting — You may need to add some italics to
special entries, or insert special characters to the final index text.

Proofing — Always have someone else do the proofing, as by the
time your index is done, you have seen these entries too many times
to catch every error.

Hand off the chapter files and the index file.

Issues in the process

This process seems simple enough, but let’s take a look at some of
the critical areas, and the issues that come into play.

When does indexing start?
One of the first decisions you have to make is when indexing should
start. Here are some general rules:

The content needs to be fairly stable, or you will need to have the
indexer reevaluate it later against the existing indexing. It needs to
have been through most developmental editing, but can be indexed
before copyediting happens. The indexer will probably find copyedit
problems during work, and should have a contact name for questions
should they arise.

If you cannot get the material stable enough to index, figure that it
will cost extra time to have the indexer go over the changes later.
Add time to your schedule for rework.

The layout of the material needs to be fairly stable, or the indexer
will need to reevaluate it again. Moving chunks of material around
can break page ranges, so it should be essentially in the final order.

You can get a head start if you finish chapters at a time and send
them for indexing. But only up to a point; as all material must have
its entries created before the editing stage begins.
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Documenting the workflow
Another issue is the workflow. Who needs the files and when do they
need them? Make sure you understand what happens at the end of
the production process so that you can schedule enough time in the
files for indexing. Remember that when index entries are being put
into the files, no one else other than the indexer can have access to
them. This can mean large chunks of time that others cannot work in
the files.

Often production people need the files right at the time indexing
needs to happen. The project team should discuss the process
together and decide when indexing can happen.

This is a common problem, and the team may feel that there is no
right time! This points out a problem area of coding indexes into
files — tying up the files for long periods of time!

File size and handoffs
Another issue is the size of the files, and managing the handoff. This
is a very complex issue for it is not just file size, but also the onsite/
offsite issue.

Whether the indexer is working offsite or onsite, they must have
complete access to the files during critical indexing stages, such as
entry input or editing. During the first stages of indexing, a chapter
at a time will be worked on, so that other people could be working in
other chapter files at the same time, and file trade-offs can be
worked out between the team. But as the editing stage begins, the
indexer must have sole access to the files for the entire stage, as
index edits happen in all the files in a very scattered fashion

If the indexer is offsite, during that stage the project team will not be
able to do any work in the files until they are returned. Make sure
everyone involved understands that impact.

Arrangements for transporting the files offsite could get complex,
especially if they are big files with embedded graphics. Will email
bog down? Would an FTP site help? Or a zip drive?
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Equipment needs
Equipment setup for indexing is Word is an important issue. The
indexer must have the same version of Word, the same fonts,
perhaps the same font display utilities (such as Adobe Type Man-
ager), the same printer drivers, and even other special tweaks to
ensure the files work the same as they do for the production team.

Here's an example of how critical equipment can be: in one project
the page breaks changed in the piece's files, even though the same
production fonts and same printer driver were installed on the
machine that the indexer was using. The index was compiled on a
different machine than the production machine, the one that sent the
files to the print shop. Word repaginated the files anyway, even with
the machine setup being exactly the same, and the page breaks were
different enough to throw off the index when it was compared to the
version of the book that went to the print shop. Compile on the same
machine that sends the files to the print shop!

Changing and re-editing indexed material
If you are going to be editing the files after indexing, you need to be
aware that some edits can affect the index’s content and its coding as
well. These things can affect the index:

Changes in page breaks
Deleting text
Adding text
Adding important graphics
File corruption
Entry field corruption or deletion
Changing bookmarks

If any of these things happen, the indexer should be notified, and
should look at the files to see if the index now has problems. Keep-
ing a change tracking system helps identify what happened.

If the files are reworked constantly while the indexer is working,
make time for each change to be evaluated.
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Translation issues
If your book is going to be translated into another language, it adds
another issue to the list.

The translators will translate the contents of each index marker as
they work. The translators also need to translate each paragraph. Be
careful of where the index markers are placed. Put them all at the
beginning of paragraphs or at the very end, so that the translator can
swipe through the entire paragraph and replace it, leaving the index
tags in place. Make sure the translator knows about the entries and
how they work so that they can translate them without corrupting
them.

It would be hard to work around these index markers if you were translating, or
if you were rewriting the book. Read on!

Updating older pieces for republication
What happens with the next edition? If this is a one-time only piece,
you have not much to worry about. But if you are working with a
constantly-revised piece, or a heavily-rewritten piece, you will be
making changes that can affect the indexing. All writers should be
trained to work around the codes, and to flag changes that affect the
indexing so it can be evaluated. If you know the book will be
rewritten, you may want to place your markers at the beginnings of
paragraphs, just as if you were translating. And teach all writers or
editors working with the files to work with the index entries show-
ing, so that none are accidently deleted, corrupted, or copied and
moved to another place in the text by mistake. Sometimes they
should be copied; sometimes they shouldn't.

If you are rewriting heavily, updating the indexing will be time-
consuming: it’s often easier to start from scratch.
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Converting to other formats
If you are going to be converting your files to an online format,
importing them into a desktop publishing program, or creating
HTML or PDF files, take some time to consider the impact on the
index. Plan ahead, as indexing in other formats is different!

For online files, make sure you are not using 3rd level subentries if
you want to do this, as online is mostly 2 levels deep. You will
probably lose your cross referencing as well — experiment and
check.

A single source tool allows you to make both print and online files
from the same set of Word files. In ones such as Doc2Help, the tool
is creating both online and print indexes.

If you are asked to single source or convert files, you must not only
figure out how to embed indexing in Word, but also figure out what
the associated conversion will do to the indexing. Test files with
each kind of item, regular entries, entries with subheads, entries with
multiple page numbers, oddly-sorted entries, cross references, and
page-ranged entries.

Also consider main heads with subentries.

What happens to main heads like "Pikes Peak," ones with no page numbers?

In print, "Pikes Peak" by itself doesn't have to lead anywhere at all.
It can sit and be a collection point for the subentries. However,
depending on which online system you are using, however, that same
entry may need to have a locator assigned to it. Some systems will
strip it out if it isn't linked to an online topic. Test your proposed
online system with these kinds of entries and see what you get after
conversion.
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If you import the files into desktop publishing software, some
programs know enough to bring the entries in. But you will probably
lose all page range and cross reference information when you do.
Test and see what you lose, and how you can work around it.

You will need to experiment with how conversion treats the index.
Work with this from the start, so that you can make sure the index is
designed to work well in the other format and in print. Do this at the
beginning before indexing begins so that the index style needed for
both formats is known.

Importing Word files with indexing in them into PageMaker means
losing your page ranges and all your cross-references. If your cross-
references do come in, they come in oddly and need to be fixed.

One great trick from Cynthia Peterson of the Visio Corportation: if
you are importing Word files into Frame, put your Word entries at
the end of the paragraphs, and put a space between each one. This
allows them to not mush up on top of each other once they are in
Frame, and makes them easy to see.

With Frame, your See and See also references in your Word file will
import very weirdly. Here’s what Frame does with See and See
also’s.

In Word, the XE fields look like:

{xe “Bayou Salado” \t “See South Park”}
{xe “Native Americans” \t “See also names of specific tribes”}

When imported into Frame, these entries wind up as:

Bayou SaladoSee South Park
Native AmericansSee also names of specific tribes

They lose that space before the See...

What they need to look like in Frame is:

<nopage>Bayou Salado. <Emphasis>See <Default Para
Font>South Park

<nopage>Native Americans:<Emphasis>See also <Default
Para Font>names of specific tribes
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Note in the See reference, a period needs to be added, and in the See
also, a colon needs to be added, and the spacing needs to be fixed. A
good macro writer could work up a macro to fix these easily.

So you can see importing indexed Word files into DTP software is
not straightforward. Test what you are planning to do with samples
before indexing.

Alternate processes you can use

The first alternate process
Here’s a viable alternative you can consider to reduce time spent in
the files. What if you were to write the index in standalone indexing
software first, then embed it? Using this method, we reap the
benefits of using indexing software for what it is good for, and using
Word for what it is good for. The main advantage is that you do not
need to tie up the live files until the very end of the process.

Here is an overview of the steps in this alternate process.

Reading material
Creating entries in standalone indexing software
Editing entries
Copying to embed codes in Word files
Compiling for review
Reviewing
Incorporating review edits
Handling revised materials
Recompiling and formatting
Proofing
Handoff

Line numbering and standalone indexing
The first step is to print out the material with line numbers or
paragraph numbers, or hand-number the printouts paragraph by
paragraph. Then index in your standalone indexing software or in a
spreadsheet using the numbers instead of page locators.
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Line numbering can be turned on by choosing Edit > Select all, then
choosing File> Page Setup, the Layout tab, and clicking the Line
Numbers box.

But remember, line numbers change if you add or delete text! This is
only a temporary solution. Printing out the files with the line num-
bers is the easiest way to work, and it gives you a referral should the
files change before putting the indexing in. Paragraph numbering is
a much better approach, and doing it by hand does not take very
long.

You can use a spreadsheet or an indexing product like Cindex to
develop your index. Keep your entries one per record, to make it
easy to sort by number later on. Put them in with the codes ready to
be pasted in — "main entry:subentry." In the next column, put in the
number.

Make notes about where you need to insert bookmarks, and what to
call each of them. Develop the index, edit it, and when satisfied with
the content, sort it in number order, and go back and embed the
codes.

The live files are only needed for the end of the process, freeing them
for copyediting and finetuning while indexing the content is happen-
ing.

Lucky indexers may be able to find Word macro writers who can
automate part of this process for them, and make it simpler to put
the entries back in.

The second alternate process � going to print with a
standalone index
If you want to, it is possible to use the index you develop in this
alternate process to go to press, without embedding any codes in the
Word files at all. This frees you to have an index in the book, but
not worry about codes in the files until later, after you have met your
press date.
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Put in hard page breaks in your files, and create your final page
numbers. You will then have to be very careful not to roll the pages,
or inform the indexer if you do make changes.

Then using an outside indexing product like Cindex, create the index
using the page numbers, and compile it into an RTF file. Attach the
RTF to your book as the index, and send it to press.

After meeting your press date, go ahead and sort the index into page
number order, and embed the codes. Check the compiled index to
make sure it matches.

Concordance builders
A note on a serious omission in this tutorial: a lot of people are
interested in automating the indexing task, but the concordance-
building tools or index-generating tools just are not there yet if you
want a good index.

With these tools there are a range of options. Some of them go
through the text, compare it to a list of stopwords such as "the" and
"an," and index the rest. You get a very poor index that takes more
effort to edit down to usability then to just index it the usual way.

With the higher-level tools you can spend hours fine-tuning the stop
lists and non-indexable passages to try and get better quality results,
but essentially, great indexes will not be the result. The best indexes
still require a brain reading and thinking about the passages, decid-
ing what is important, and inputting the data.

If you are into quality indexes, concordance builders are not the
answer.
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As an example, one piece that I indexed had eight pages in a chapter
talking about telecom companies. On the ninth page of the chapter,
the author stopped calling them "telecom companies" and started
referring to them as "vendors." Only a brain would realize these are
synonyms. A concordance builder would not, and would only pick
up the first 8 pages for the "telecom" entries, leaving the reader in
ignorance that more material was available in the book. Similarly, in
the "v" section of the index, only the ninth page on would appear,
again leaving the reader with scattered information.

Word�s concordance tool
That said, if you would like to experiment with Word’s AutoMark
feature, which is somewhat like a concordance builder, here are the
steps.

One way is supposedly to use the Mark All button in the Mark Index
Entry dialog box. But this does not seem to work very well, so don't
bother with it.

In the second method, you must build a concordance file, a file that
lists all the terms for AutoMark to search for, and the corresponding
index entries that should be placed when a term is found.

Create a new blank document. In it, create a blank two column table
by clicking the Table tool, and dragging the right number of col-
umns.

In the first column, type in the text you want Word to search for.
When it finds this text, it will place an index entry by it containing
the text you put into the second column. In the second column, type
the main and subentry, but without any field codes.

Concordance file for AutoMarking
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If you want Word to find all variations of a word, such as remove,
removing, removal, you must list those separately.

Save the file.

Open the file you want to AutoMark.

Go to the end of the document, and choose Insert > Index and
Tables, and click the AutoMark box. Choose your concordance file,
and click OK.

Specifying the AutoMark file to use.

Index entries will now appear in your file.
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Then generate your index and see what you get.

These results only reflect an 8-page file, so they are not out of
control. But a 100-page book on Pikes Peak would lead to a large
number of undifferentiated page numbers, not of much use to a
reader. It takes so much time to build a decent concordance file, one
that will catch all the important topics, that it really might be easier
to just index the files.

New products that may help
Currently, several vendors are working on add-on tools to help
indexers who need to work in Word. By the time this tutorial is
released, you may have more choices. Until the products are actually
out the door, however, we cannot really address how they will work
and whether they will fill your needs. This tutorial will be updated as
more information becomes available.

Scheduling

Scheduling issues
So how much time should you allow for a typical project in Word?
This can be a hard question to answer, as technical problems can
slow one project down while another flies through with no stop-
pages.

On the Wright Information web site is an Excel spreadsheet that will
help you figure out how much time to estimate for indexing. On the
worksheet are formulas for plain Word-based indexing.
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Exercise: scheduling

Download the spreadsheet Formula.xls from the web site (http://
www.wrightinformation.com/Formula.xls). Let’s look at how you
can use the first sheet to figure out the amount of time to allow for
indexing. Make a copy of the spreadsheet before experimenting.

Each step in the indexing process has been given an estimated
percentage of the time it takes up in the process, and for those who
need to streamline the process, required steps are marked with **.

Formula spreadsheet: these are 8-hour days

Enter the number of pages for your piece in the marked box. For
example, try entering 450.

Automatically, the number of days needed for each step is calcu-
lated, as well as the number of days needed for the indexer.

You can simplify the process on a copy of the spreadsheet if you like
— go ahead and experiment!

http://www.wrightinformation.com/Formula.xls
http://www.wrightinformation.com/Formula.xls
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Tradeoffs
If you do not have enough time in your schedule for indexing, what
can you do?

Some effective techniques are:

Deliver material in chunks
Cut back on review stages
Start earlier and rework index

Some ineffective techniques are:

Reduce depth
Write fewer entries
Reduce cross-references
Use multiple indexers

Conclusion

We hope you have gotten a lot out of this tutorial. We have tried to
cover most of the issues and techniques needed for Microsoft Word
indexing. A list of basic indexing resources is included in the
Appendix for you.

May your indexes always compile!
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Appendix
Here are some resources on basic indexing techniques.

American Society of Indexers Web site: http://www.asindexing.org

Bonura, Larry. The Art of Indexing. New York: John Wiley & Sons,
1994

Index-L listserv. Instructions for subscribing are at:
http://www.asindexing.org/discgrps.htm#indexl

IndexStudents listserv: Instructions for subscribing are at:
http://www.onelist.com/subscribe.cgi/indexstudents

Lathrop, Lori. Basic Indexing Techniques.
http://www.bwa.org/articles/ref9.htm

Mulvany, Nancy C. Indexing Books. Chicago: The University of
Chicago Press, 1994

Philadelphia ASI chapter's web site listing of articles and links.
Look on the main page for the link to their index of articles: http://
www8.bcity.com/phila_asi/

Society for Technical Communication's Indexing SIG Web site:
http://stc.org/pics/indexing/

USDA Graduate School Correspondence Study Program courses in
Basic Indexing and Advanced Indexing: 202-720-7123

Wellisch, Hans. Indexing from A to Z. New York: H.W. Wilson.
2nd. edition, 1996

http://www.asindexing.org
http://www.asindexing.org/discgrps.htm#indexl
http://www.onelist.com/subscribe.cgi/indexstudents
http://www.bwa.org/articles/ref9.htm
http://www8.bcity.com/phila_asi/
http://www8.bcity.com/phila_asi/
http://stc.org/pics/indexing/

